Jump to content
  • 0

Mangos extractor build failed?


Question

Hi, little problem

I followed the Windows build guide and managed to build Mangos Three, but I'm having problems with the extractor which seems to be missing parts.

I can extract the map files and DBC files (I pick all the extraction options), all the creation options are greyed out, so after a few moments I'm left with a DBFilesClient folder and World folder containing a Maps folder, which then contains folders named after the zones, which are filled with *.adt files.

When I rebuilt the solution, I had several failures, and I presume they all/most relate to the extractor, as I currently have realmd.exe running fine, but can't start mangosd.exe without these map files. Substitution doesn't seem to work, as it tells me they're from an non-compatible version.

If I'm overlooking something, or you need a log file from the build, let me know what you need and where it should be.

Screenshot (46).png

Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

whoa, this is a separate project and is not the main extractors which are supplied with the server.

Assuming you have used easybuild (after running the patch file for mangos three), you should enable building of the 'Extraction Tools' and build.

When complete, the extraction files will be in a folder like serverThree_build/bin/Release/Tools
- Follow the guide on extraction and you should be sorted.

 

  • Like 1
Link to post
Share on other sites
  • 0

sorry it seems thats i cant build it even after my mmaps are done, i still get tast was canceled and when i wait it cancel the whole build i dont know why.

 

maybe someone else here can help you. i hear that the error you get are from a update, if you want you can try go back to about 3 of june it should work then.-

  • Like 1
Link to post
Share on other sites
  • 0

you can try clone it this way:

21 hours ago, Shaorin said:

and then after do:

git checkout 6aeb735b8d62abc6ab8b406175072dbb88c60688

 

this will give you a worning saying you are not at the last commit. but it should work here. it was when i use mangos 3 last time.

to the commit

if you need to go back more.

 

hope it works for you.

  • Like 1
Link to post
Share on other sites
  • 0

Thanks for all your help Shaorin, but I can only presume that the problem either existed to before my build environment was supported, or it's my build environment itself that's the problem. I'll update this post when I can get back onto my desktop, but I spent last night compiling older versions with varying degrees of success, but no tools ever came out unfortunately.

Link to post
Share on other sites
  • 0

Windows 10 Pro Ver 1703, Intel Core i5 4670K 3.4GHz, 8GB RAM, 64-bit OS
OpenSSL (32-bit) 1.0.2j 26 Sep 2016
OpenSSL (64-bit) 1.0.21 25 May 2017
Cmake 3.9.0-rc2 (I have only just reverted back to the latest edition, all my builds last night were with the included version)
Microsoft Visual Studio Community 2015 14.0.25431.01 Update 3 with the required components installed (C++ support, etc.)
MySQL 5.7 64-bit

Link to post
Share on other sites
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy Terms of Use